Aktuelle Zeit: Montag 1. März 2021, 11:14

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




 Seite 1 von 1 [ 3 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Firefox von VMware Horizon / Microsoft Visual C++ lahmgelegt
BeitragVerfasst: Donnerstag 18. Februar 2021, 20:50 
Brennmeister
Benutzeravatar

Registriert: Sonntag 18. September 2005, 16:40
Beiträge: 4773
Ich habe gerade mal wieder einen Software-Albtraum erlebt. Ich wollte per VPN auf digitale Inhalte einer Universitätsbibliothek zugreifen, wofür neben dem VPN-Client bisher immer auch ein kleines Citrix-Programm verwendet werden musste. Nun wurde im System der Universitätsbibliothek allerdings etwas umgestellt und man musste nun statt des Citrix-Clients die Software VMware Horizon installieren. Allerdings brach das Setup der Software bei mir aus unbekannten Gründen ab und ich bekam die Fehlermeldung "Installation fehlgeschlagen" zu sehen. Ich habe dann keinen Versuch mehr unternommen, den Grund für das Installations-Problem zu finden, da ich das digitale Medium, auf das ich eigentlich zugreifen wollte, nicht dringend benötigte.

Jetzt begann allerdings der Albtraum. Ich wollte einfach nur meinen Firefox-Browser starten, woraufhin ich die folgende Meldung zu sehen bekam:

Dateianhang:
VMWare Fehlermeldung.png

Als ich dann nochmal versuchte, Firefox zu öffnen, erschien zwar das gewohnte Fenster, doch reagierte kein einziges Element von Firefox auf Mausklicks. Ich konnte also weder das Menü aufrufen noch URLs ansteuern. Firefox war praktisch tot oder wenigstens komplett paralysiert. Ein Neustart des PCs half ebenfalls nichts. Selbst ein auf der Festplatte noch gespeicherter Firefox Portable funktionierte nicht mehr und zeigte mir beim ersten Start die gleiche Fehlermeldung. Ich habe dann über Microsofts Edge-Browser panisch nach möglichen Ursachen gesucht. Als Problem hat sich dann herausgestellt, dass durch den fehlgeschlagenen Versuch, VMWare Horizon zu installieren, entweder eine fehlerhafte Version von Microsofts Visual C++ installiert oder aber eine bereits auf den PC vorhandene Version von Microsoft Visual C++ beschädigt wurde.

Lösen konnte ich das Problem nur dadurch, dass ich in Windows 10 über Einstellungen > Apps die folgenden Versionen von Microsoft Visual C++ (x86 und x64) habe reparieren lassen (über "Ändern" > "Reparieren"):

Dateianhang:
Screenshot 2021-02-18 193933.png

Diskutiert wird das Problem (auf Englisch) auch hier: https://support.mozilla.org/en-US/questions/1290656


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.



_________________
Gigabyte GA-Z97X-UD3H ● Intel Xeon E3-1231 v3 ● ASUS ROG STRIX-GTX1070-O8G-GAMING ● Crucial Ballistix Sport 16GB DDR3-1600 ● Samsung SSD 850 EVO (500GB) ● Samsung SSD 860 EVO (500GB) ● HGST Deskstar NAS 3TB ● Cooler Master VS-Series V650SM (650W) ● ASUS Xonar DX ● ASUS BW-16D1HT ● Asus PB248Q ● Sharkoon T28 | @ Brennmeister seit 03.09.2002
Offline
 Profil  
 
 Betreff des Beitrags: Re: Firefox von VMware Horizon / Microsoft Visual C++ lahmge
BeitragVerfasst: Mittwoch 24. Februar 2021, 18:12 
Administrator
Benutzeravatar

Registriert: Donnerstag 22. September 2005, 20:01
Beiträge: 6113
Wohnort: /etc/
geh mal in den Installationsordner von FF und such nach der vcruntime140.dll und benenne sie in vcruntime140_1.dll um .

Zitat:
right-click vcruntime140.dll > Copy
right-click a blank area of the folder > Paste

find the copy (e.g., vcruntime140 - Copy.dll) and right-click > Rename it to vcruntime140_1.dll


ansonsten mal im Windows Ordner nach den DLLs suchen und ins FF Installationsverzeichniss kopieren



_________________
"Die Falschheit herrschet, die Hinterlist bei dem feigen Menschengeschlechte."

MBQ I : ASRock Z77 Pro 4 - i5 3570k@4.2GHz - 16GB XMS3@1800- R9 290 Winforce 3xOC@14.9.2 - 1040/1250 - 2*WD1002FAEX@RAID0 + WD2002FAEX - 2*SDSSDHP128GB@RAID0 - Creative Audigy 2ZS - CPU@BQ SP-450 + GPU@BQ PP-CM-730 - PLX2783HSU@74Hz - Arvo + Bloody V7M - Win8.1 Pro WMC 64Bit
Offline
 Profil  
 
 Betreff des Beitrags: Re: Firefox von VMware Horizon / Microsoft Visual C++ lahmge
BeitragVerfasst: Mittwoch 24. Februar 2021, 21:22 
Brennmeister
Benutzeravatar

Registriert: Sonntag 18. September 2005, 16:40
Beiträge: 4773
Danke für deinen Tipp! Ich konnte das Problem aber schon, wie im ersten Beitrag geschrieben, durch die automatische Reparatur bestimmter Microsoft Visual C++ Installationen lösen.



_________________
Gigabyte GA-Z97X-UD3H ● Intel Xeon E3-1231 v3 ● ASUS ROG STRIX-GTX1070-O8G-GAMING ● Crucial Ballistix Sport 16GB DDR3-1600 ● Samsung SSD 850 EVO (500GB) ● Samsung SSD 860 EVO (500GB) ● HGST Deskstar NAS 3TB ● Cooler Master VS-Series V650SM (650W) ● ASUS Xonar DX ● ASUS BW-16D1HT ● Asus PB248Q ● Sharkoon T28 | @ Brennmeister seit 03.09.2002
Offline
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
 Seite 1 von 1 [ 3 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  

cron