Aktuelle Zeit: Mittwoch 22. Mai 2024, 23:05

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




 Seite 1 von 1 [ 11 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Renitente ATAPI-Devices wieder auf Ultra-DMA Kurs bringen
BeitragVerfasst: Montag 27. August 2007, 00:16 
Moderator
Benutzeravatar

Registriert: Freitag 16. Dezember 2005, 15:38
Beiträge: 1498
Wohnort: Düsseldorf
Wenn gar nichts mehr geht
oder
Wie man renitente ATAPI-Devices wieder auf Ultra-DMA Kurs bringt

Jeder kennt das: Von einem auf den anderen Tag verhält sich ein Brenner seltsam.
  • Die Transferrate beim Lesen bricht zusammen, DVDs ruckeln
  • Die Warndioden für den Einsatz von Buffer Underrun Vermeidungstechniken flackern beim Brennvorgang im Dauerfeuer
  • 16x Brennen klappt nicht mehr oder dauert so lang, daß man denkt, der brennt ja nur 2x.
  • Qualitätsscans zeigen ungewöhnliche Scanverläufe für Rohlinge, die man meint, gut zu kennen. Insbesondere tritt eine PIF 1 Dauermessung auf.

Ursachen sind meist keine erkennbar. Evtl. fällt einem noch mal ein, daß man da vor ein paar Tagen beim Scannen mal 'ne ziemlich grottige DVD hatte, aber in den meisten Fällen bleibt die Ursache unklar, besonders, wenn der Fehler bei einer Festplatte auftritt (siehe z.b. http://www.bm-community.de/ftopic11274.html).

Doch genau eine solche, schlecht lesbare, DVD ist für das Desaster beim DVD-Brenner verantwortlich. Bei Festplatten ist es meist ein defekter Sektor, der später von der Festplattenelektronik "weggemappt" wird. Aber warum?

Windows (ab 2000!), bzw. der ATAPI-Treiber, prüft bei allen Lesevorgängen von Datenträgern permanent u.a. die Zuverlässigkeit der Datenübertragung im System. Kommt es zu Fehlern bei Datenträgerzugriffen, wird nach einiger Zeit oder einigen erfolgosen Zugriffsversuchen in wenigen Schritten die mögliche Übertragungsgeschwindigkeit der zugehörigen Schnittstelle zum Laufwerk reduziert. Hierzu wird ein interner Zähler verwendte, der jeweils nach 6 Fehlern die Übertragungsgeschwindigkeit um eine Stufe herabsenkt.
Benimmt sich ein Laufwerk (bzw. der Datenträger im Laufwerk) im Anschluß wieder "nett", bleibt es bei temporären Einschränkungen (z.B. Herabstufung von Ultra-DMA 5 auf PIO), die vom Anwender über den Geräte-Manager wieder einfach zurückgesetzt werden können. Leider wird der interne Zähler dabei nicht wieder auf "0" zurückgesetzt, so daß beim nächsten Fehler, das Theater wieder von vorne beginnt.

Treten somit Leseprobleme wiederholt auf, wird die Schnittstelle dauerhaft auf PIO zurückgesetzt und die Auswahlmöglichkeit im Datei-Manager "ausgegraut". Wie man im letzteren Fall das Problem beheben kann, wird im nächsten Schritt beschrieben.



_________________
Heute ist nicht alle Tage, ich komm' wieder, keine Frage ;-)

Vancouverona
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 00:18 
Moderator
Benutzeravatar

Registriert: Freitag 16. Dezember 2005, 15:38
Beiträge: 1498
Wohnort: Düsseldorf
Schritt 1: Lösung über den Geräte-Manager
oder:
Eleganz ist nicht alles

Voraussetzung 1: Die Hardware ist in Ordnung, alle Laufwerke sind hardwareseitig richtig verschaltet (ordentliche und festsitzende Kabel, korrekte Master-/Slave-Jumperung, genügend Energie) und auch im BIOS mit allen "Finessen" eingetragen sind (Ultra-DMA Modus, 32bit Datentransfer, etc.).
Voraussetzung 2: Die letzte Datensicherung liegt nicht wesentlich länger als 30 Minuten zurück!!

Dann sollten folgende Schritte in 90% aller Fälle zum Ziel führen:
  1. Starte den Geräte-Manager (wer nicht weiß, wie das geht, kauft sich besser einen neuen Rechner :devil:)
  2. Öffne den Ast IDE ATA/ATAPI-Controller
  3. Wähle den IDE-Kanal, an dem das "zu langsame Laufwerk" hängt.
  4. Klicke mit der rechten Maustaste auf den IDE-Kanal
  5. Wähle "Deinstallieren" und bestätige ein paar Mal mit "JA" und "OK"
  6. Fahre den Rechner herunter und starte ihn neu.
  7. Stoßgebete können helfen, sind aber nicht zwingend notwendig :up:
  8. Melde Dich wieder an und prüfe im Geräte-Manager, ob Dein Eingriff erfolgreich war.
Für den Fall, daß Du erfolgreich warst, klopfe Dir auf die Schulter (sonst tut's ja keiner :))
Für den Fall, daß das Laufwerk immer noch beharrlich im PIO-Modus verbleibt, hilft Dir der nächste Teil.



_________________
Heute ist nicht alle Tage, ich komm' wieder, keine Frage ;-)

Vancouverona
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 00:20 
Moderator
Benutzeravatar

Registriert: Freitag 16. Dezember 2005, 15:38
Beiträge: 1498
Wohnort: Düsseldorf
Schritt 2: Hardcore-Registry-Hacking
oder
Die Operation am offenen Hirnstamm

Voraussetzungen: Siehe Schritt 1.

Windows speichert seine Messungen und daraus resultierende "Einschätzungen" zur Qualität der angeschlossenen Datenträgergeräte in der Registry ab. Je nach den dort enthaltenen Werten und verwendeten Parametern läßt sich ein Laufwerk mit der Methode 1 wieder vom PIO-Modus auf den Ultra-DMA-Modus zurücksetzen.

Die Informationen liegen (beim Standard Microsoft IDE ATA/ATAPI-Treiber!!) unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}.
Bei NVIDIA- oder VIA-Chipsätzen (mit eigenen Treibern!!) könnten hier andere Pfade auftreten, die ich nicht kenne und daher hier auch nicht beschreiben kann. Vielleicht läßt sich dort aber eine abgeleitete Technik verwenden.

Die numerischen Unterzweige stellen jeweils den Controller dar, sowie die jeweiligen "Primären" und "Sekundären" IDE-Kanäle.

- 0000 ist dabei der erste Controller (meist IDE ATA/ATAPI)
- 0001 ist der erste primäre Kanal
- 0002 ist der erste sekundäre Kanal

Bei modernen Boards mit SATA Ports kommen dann noch

- 0003 für den zweiten Controller (SATA)
- 0004 ist der zweite primäre Kanal
- 0005 ist der zweite sekundäre Kanal

Wird ein Anschluß im System neu angelegt, ohne daß ein Gerät angeschlossen wird, dann enthält er nur die nachfolgenden Parameter und Werte (mein zweiter SATA-Port ist immer noch leer) für die einzelnen Anschlüsse:

"EnumPropPages32"="storprop.dll,IdePropPageProvider"
"InfPath"="mshdc.inf"
"InfSection"="atapi_Inst_secondary"
"ProviderName"="Microsoft"
"DriverDateData"=hex:00,80,62,c5,c0,01,c1,01
"DriverDate"="7-1-2001"
"DriverVersion"="5.1.2600.2180"
"MatchingDeviceId"="secondary_ide_channel"
"DriverDesc"="Sekundärer IDE-Kanal"
"MasterDeviceType"=dword:00000000
"MasterDeviceDetectionTimeout"=dword:00000001
"MasterDeviceTimingMode"=dword:00000000
"SlaveDeviceType"=dword:00000000
"SlaveDeviceDetectionTimeout"=dword:00000001
"SlaveDeviceTimingMode"=dword:00000000

Ein "renitenter" IDE-Anschluß weist dagegen auch noch weitere Parameter auf. Die nachfolgenden Parameter

- "MasterIdDataCheckSum"
- "MasterDeviceTimingMode"
- "MasterDeviceTimingModeAllowed"
- "UserMasterDeviceTimingModeAllowed"

(die es mit "Slave" auch noch mal für den Slave-Anschluß gibt) sind dabei die Ursache, für das Scheitern von Schritt 1. Ausgelöst wird das dadurch, daß ein interner Fehlerzähler mehr als 6 Fehler festgestellt hat und daher der ATAPI-Treiber eine Stufe heruntergesetzt wird.

Wenn man also alle IDE-Kanäle (im Bezug auf "Master"- und "Slave"-Parameter) auf die nachfolgenden 6 Parameter reduziert:

- "MasterDeviceType"=dword:00000000
- "MasterDeviceDetectionTimeout"=dword:00000001
- "MasterDeviceTimingMode"=dword:00000000
- "SlaveDeviceType"=dword:00000000
- "SlaveDeviceDetectionTimeout"=dword:00000001
- "SlaveDeviceTimingMode"=dword:00000000

dann gibt Windows beim nächsten Systemstart allen IDE ATA/ATAPI/SATA-Geräten die Chance, sich neu mit der Schnittstelle über Timings, Übertragungsraten und dergleichen auszutauschen.

Gibt man nun pro IDE-Kanal noch den Parameter

- "ResetErrorCountersOnSuccess" = dword:00000001

ein, dann wird der von Windows intern verwendete Fehlerzähler beim ersten erfolgreichen Lesevorgang wieder auf "0" gesetzt (was sonst nicht geschieht!!). Hierdurch tritt der Effekt des "Verlangsamens" des IDE-Kanals nicht mehr ganz so häufig auf. Näheres hierzu findet man bei Microsoft.

Wie wichtig ein solcher Artikel gewesen wäre, sieht man übrigens hier.



_________________
Heute ist nicht alle Tage, ich komm' wieder, keine Frage ;-)

Vancouverona
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 09:29 
Brennmeister ehrenhalber

Registriert: Samstag 17. September 2005, 19:22
Beiträge: 1268
Wohnort: Betelgeuse
Hatte das Problem zwar noch nicht, finde aber, das wäre schon einen Sticky wert. :aok:



_________________
bambam
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 10:50 
Co-Admin
Benutzeravatar

Registriert: Montag 19. September 2005, 19:19
Beiträge: 13429
Wohnort: 127.0.0.1
bambam hat geschrieben:
Hatte das Problem zwar noch nicht, finde aber, das wäre schon einen Sticky wert. :aok:


hab ich doch schon gemacht :stare: ...



_________________
PC Adé ... Hab nur noch mein Notebook, meine PS4 und meine DSLR-Ausrüstung :devil: :prost:
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 12:10 
Brennmeister ehrenhalber

Registriert: Samstag 17. September 2005, 19:22
Beiträge: 1268
Wohnort: Betelgeuse
BenGurion hat geschrieben:
bambam hat geschrieben:
Hatte das Problem zwar noch nicht, finde aber, das wäre schon einen Sticky wert. :aok:


hab ich doch schon gemacht :stare: ...


Hab' ich auch schon gemerkt... :afraid: :lol:



_________________
bambam
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Montag 27. August 2007, 23:27 
Moderator
Benutzeravatar

Registriert: Freitag 16. Dezember 2005, 15:38
Beiträge: 1498
Wohnort: Düsseldorf
Rückschau
oder
Wenn wir gewußt hätten, ...

Ich habe mir heute - so als Nachbrenner - mal die Mühe gemacht und mal einige Threads aus diesem Jahr rausgesucht, in denen die obigen 3 Beiträge hätten hilfreich sein können. Dazu habe ich noch einen Link gefunden, der das ganze Thema auch ziemlich breit erörtert, allerdings - IMHO - etwas unstrukturiert.

Hier die Links...

Und hier der Link in die weite Welt...
Das angegebene Programm habe ich mir mal angesehen. Das haut letztlich nur die von mir schon angemerkten Parameter

- "MasterIdDataChecksum"
- "SlaveIdDataChecksum"
- "MasterDeviceTimingModeAllowed"
- "SlaveDeviceTimingModeAllowed"

für Master und Slave weg und gibt im Anschluß eine Erfolgsmeldung aus.

Mal schauen, ob ich mir auch noch ein solches "Tool" baue.



_________________
Heute ist nicht alle Tage, ich komm' wieder, keine Frage ;-)

Vancouverona
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Mittwoch 29. August 2007, 22:13 
Gefällt's hier richtig gut

Registriert: Sonntag 18. September 2005, 00:07
Beiträge: 278
Mir ist es mal passiert dass die Festplatte in den PIO-Modus gefallen ist, das hat den Rechner deutlich spürbar verlangsamt. Das ging sogar soweit, dass Winamp aussetzer gezeigt hat, wenn man Fenster verschoben hat, Spiele haben extrem gelaggt, wenn auf die Festplatte zugegriffen wurde etc.
Hatte das Problem damals mit einer Anleitung aus dem Internet gelöst, soweit ich mich erinnern kann war sie so ähnlich wie der Teil "Schritt 2: Hardcore-Registry-Hacking". So eine Anleitung kann in solch einem Fall echt nützlich sein !



_________________
Legend of the green dragon (RPG-Browsergame)
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Freitag 7. September 2007, 15:14 
Brennmeisteranwärter
Benutzeravatar

Registriert: Montag 19. September 2005, 02:44
Beiträge: 998
dazu braucht es gar keinen aufregenden tools
man erstelle eine normale textdatei mit dem editor wo das zwischen den ******* drin steht:

**********************
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001\]
"SlaveDeviceTimingMode"=-
"MasterDeviceTimingMode"=-
"MasterIdDataCheckSum"=-
"SlaveIdDataCheckSum"=-
"MasterDeviceTimingModeAllowed"=-
"SlaveDeviceTimingModeAllowed"=-
"UserMasterDeviceTimingModeAllowed"=-
"UserSlaveDeviceTimingModeAllowed"=-
"ResetErrorCountersOnSuccess" = dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002\]
"SlaveDeviceTimingMode"=-
"MasterDeviceTimingMode"=-
"MasterIdDataCheckSum"=-
"SlaveIdDataCheckSum"=-
"MasterDeviceTimingModeAllowed"=-
"SlaveDeviceTimingModeAllowed"=-
"UserMasterDeviceTimingModeAllowed"=-
"UserSlaveDeviceTimingModeAllowed"=-
"ResetErrorCountersOnSuccess" = dword:00000001

***********************
oder alternativ die schlüssel ganz löschen und neu schreiben:




***********************

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001\]
[-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002\]

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001\]

MasterDeviceType"=dword:00000000
"MasterDeviceDetectionTimeout"=dword:00000001
"MasterDeviceTimingMode"=dword:00000000
"SlaveDeviceType"=dword:00000000
"SlaveDeviceDetectionTimeout"=dword:00000001
"SlaveDeviceTimingMode"=dword:00000000
"ResetErrorCountersOnSuccess" = dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002\]

MasterDeviceType"=dword:00000000
"MasterDeviceDetectionTimeout"=dword:00000001
"MasterDeviceTimingMode"=dword:00000000
"SlaveDeviceType"=dword:00000000
"SlaveDeviceDetectionTimeout"=dword:00000001
"SlaveDeviceTimingMode"=dword:00000000
"ResetErrorCountersOnSuccess" = dword:00000001

*************************


anschliessend zb. als "hauwechdenpio.reg" oder was auch immer abspeichern (ichtig ist nur die änderung .reg

dann doppelklick auf die datei und alle hier beschriebenen änderungen sind vollzogen 8-)



_________________
Vista?
wer braucht denn diesen Mist da?

Einmaliges Angebot:
Bestellen sie jetzt das gesamte Internet auf 6.827.325.212 DVD´s, oder auf 3 CD´s ohne Pornos!
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Freitag 7. September 2007, 17:52 
Moderator
Benutzeravatar

Registriert: Freitag 16. Dezember 2005, 15:38
Beiträge: 1498
Wohnort: Düsseldorf
Hallo Luc,

so wie Du das beschreibst, klappt das nur für die ersten beiden Controller.



_________________
Heute ist nicht alle Tage, ich komm' wieder, keine Frage ;-)

Vancouverona
Offline
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: Freitag 7. September 2007, 20:40 
Brennmeisteranwärter
Benutzeravatar

Registriert: Montag 19. September 2005, 02:44
Beiträge: 998
nörgelpeter :D

war auch nur als denkanstoss gedacht. ist entstanden, weil bei mir dort die optik hängt- der rest läuft eh über in dieser hinsicht störunanfälliges raid.

mal grade 000x\ in den passenden controller umwandeln sollte hier aber jeder schaffen. und in zukunft reicht dann ein klick

man muß für diese dönekens nun wirklich kein aufwändiges programm schreiben und hat so eine quicki-lösung, ohne sich immer durch die reg hangeln zu müssen



_________________
Vista?
wer braucht denn diesen Mist da?

Einmaliges Angebot:
Bestellen sie jetzt das gesamte Internet auf 6.827.325.212 DVD´s, oder auf 3 CD´s ohne Pornos!
Offline
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
 Seite 1 von 1 [ 11 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  

cron